Exp no: 1                                                                                          Date:

CREATE A DISTRIBUTED APPLICATION TO DOWNLOAD VARIOUS Files from various server USING REMOTE METHOD INVOCATION
AIM: 
   To  create a program to download files from various servers using RMI.
DESCRIPTION:

· Define the interface.

· Interface must extend Remote

· All methods must throw an exception Remote Exception individually

· Implement the interface.

· Create a server program.

· Create a Client Program.

· Generate stubs and skeletons using rmic tool.

· Start the server.

· Start the client.

· Once the process is over stop the client and server respectively.

EX.NO:1
                   
CREATE A DISTRIBUTED APPLICATION TO DOWNLOAD

VARIOUS Files from various server using
REMOTE METHOD INVOCATION
DATE:
Codings:

AddServerIntf.java

import java.rmi.*;

public interface AddServerIntf extends Remote

{


double add(double d1,double d2)throws RemoteException;

}

AddServerImpl.java
import java.rmi.*;
import java.rmi.server.*;

public class AddServerImpl extends UnicastRemoteObject implements AddServerIntf

{


public AddServerImpl()throws RemoteException


{


}


public double add(double d1,double d2)throws RemoteException


{



return d1+d2;


}

}

AddServer.java

import java.net.*;

import java.rmi.*;

public class AddServer

{


public static void main(String args[])


{


try


{



AddServerImpl addServerImpl=new AddServerImpl();



Naming.rebind("AddServer",addServerImpl);


}


catch(Exception e)


{


}

}
}
AddClient.java
import java.rmi.*;

public class AddClient

{


public static void main(String args[])


{


try


{



String addServerURL="rmi://"+args[0]+"/AddServer";


AddServerIntf addServerIntf=(AddServerIntf)Naming.lookup(addServerURL);



System.out.println("The First Number is:"+args[1]);



double d1=Double.valueOf(args[1]).doubleValue();



System.out.println("The Second Number is:"+args[2]);



double d2=Double.valueOf(args[2]).doubleValue();



System.out.println("The sum is "+addServerIntf.add(d1,d2));


}


catch(Exception e)


{



System.out.println("Exception: "+e);


}

       }

}

Execution Steps:
compile all the 4 programs.

Generate Stub by,

COMMAND
rmic AddServerImpl

This command generate the AddServerImpl_Stub.class

Step 2:

Install files on client and server machines

copy the compiled file to client and server directory or machine
CLIENT: 

      1.AddClient.class 

      2.AddServerImpl_Stub.class

      3.AddServerIntf.class

SERVER:

1. AddServerIntf.class

2. AddServerImpl_Stub.class

3. AddServerImpl.class

4. AddServer.class

STEP 3:

Start the rmi registry on the server machine by,

start rmiegistry
STEP 4:

server side machine or folders by,
java AddServer
STEP 5:

Client side machine or folder by,

 java AddClient serverip 8 9
java AddClient 127.0.0.1  8 9
OUTPUT :
The first number is: 8

The second number is: 9
The sum is: 17

RESULT: 

                     Thus the   program for  downloading  files from various servers using RMI was created and executed successfully.

Exp no: 2
                                                                          Date:

 CREATE A JAVA BEAN TO DRAW VARIOUS GRAPHICAL SHAPES USING BDK OR WITHOUT BDK

AIM: 

To Create a Java Bean to draw various graphical shapes using BDK or without Using BDK.
DESCRIPTION:

· Start the Process.

· Determine the necessary process to be determined.
· Then declare the necessary process for their execution process.
· Set the class path for java process to be determined.
· Write the Source code for the executable operations.

· Then each and every simulation process has to be executed separately.
· If then given condition have been satisfied then execute the terminal process.

· Finally execute the resultant process with optimize source code.
EX.NO:2


CREATE A  JAVA BEAN TO DRAW VARIOUS GRAPHICAL

SHAPES AND DISPLAY IT  USING OR WITHOUT
                                 USING BDK
DATE:

Codings:

import java.io.*;

import java.awt.*;

public class shape extends Canvas implements Serializable

{

private boolean shape;


public shape()


{

setSize(new Dimension(100,200));



shape=false;


}


public void setShape(boolean a)


{



this.shape=a;



repaint();


}


public boolean getShape()


{



return shape;


}


public void paint(Graphics g)


{



Dimension d=getSize();



if(shape)



{




g.drawRect(100,100,100,100);




g.drawRect(120,70,80,100);




g.drawRoundRect(10,120,200,220,20,20);



}

else



{




g.drawOval(50,50,70,70);




g.drawOval(130,20,85,60);




g.drawArc(200,80,80,80,0,180);



}


}

}

Execution Commands:

F:\MWT LabPgms\JavaBean> set PATH=%PATH%.; F:\MWT LabPgms\JavaBean

F:\MWT LabPgms\JavaBean> set CLASSPATH=%CLASSPATH%.; F:\MWT LabPgms\JavaBean

F:\MWT LabPgms\JavaBean>javac shape.java

F:\MWT LabPgms\JavaBean>jar cf shape.jar *.class

Search and Run the following run.bat file from Bean Development Kit

D:\beans\beanbox\run.bat

Load the jar file by using the File Menu

File>LoadJar> Choose shape.jar file location and load it

Now we can view the shape on ToolBox window, Draw and Drop it into BeanBox window

and Draw different shapes.

OUTPUT:
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RESULT: 

        Thus the   program for  Creating a Java Bean to draw various graphical shapes using BDK or without Using BDK was created and executed successfully.
Exp no: 3









Date:

          DEVELOP AN ENTERPRISE JAVA BEAN FOR BANKING



                    OPERATIONS
AIM: 
            To create a component for banking operations using EJB.
DESCRIPTION:  

· Start the process. 
· Then determine the necessary process for the program to be developed.
· Determine the class path to be determined.
· Then declare the necessary process for their execution process.
· Write the Source code for the executable operations.

· Then each and every simulation process has to be executed separately.
· Set class path for the required process.

· Then execute the process for each path class. 
· Execute the finally to envelope the required process.

EX.NO:3


DEVELOP AN ENTERPRISE JAVA BEAN FOR BANKING              OPERATIONS
DATE:

Codings:

BankHome.java

import java.rmi.RemoteException;

import javax.ejb.CreateException;

import javax.ejb.EJBHome;

public interface BankHome extends EJBHome 
{

public BankRemote create() throws RemoteException, CreateException;

}

BankRemote.java
import java.rmi.RemoteException;

import javax.ejb.CreateException;

import javax.ejb.EJBObject;

public interface BankRemote extends EJBObject 
{
public void deposit(float amt) throws RemoteException, CreateException;


public void withDraw(float amt) throws RemoteException, CreateException;


public String getBalance() throws RemoteException, CreateException;

}

BankBean.java
import java.rmi.RemoteException;

import java.sql.Connection;

import java.sql.ResultSet;

import java.sql.Statement;

import javax.ejb.EJBException;

import javax.ejb.SessionBean;

import javax.ejb.SessionContext;

import javax.security.auth.login.AccountException;

public class BankBean implements SessionBean 
{

public float amount;


public String pwd, accNum, name, sql;


private Connection con;


private Statement stat;


private ResultSet rs;


SessionContext sesCtx;
public void ejbCreate()
{



System.out.println("ejbCreate Method Called...");



try 
{



con = new DatabaseAdaptor().getConnection();




stat = con.createStatement();




sql = "Select balance from AccTable where accountNo="+accNum+"";




System.out.println(sql);




rs = stat.executeQuery(sql);




if(rs.next())
{





amount = rs.getFloat(1);




}



} 


catch (Exception e) 
{




e.printStackTrace();



}


}

public float getBalance()
{



return amount;


}


public void deposit(float amt)
{



amount = amount + amt;


}


public void withDraw(float amt)throws AccountException
{



if(amount < amt) throw new AccountException("Insufficient Balance!...");



if((amount - amt)<500) throw new AccountException("Insufficient Balance!...");



amount = amount - amt;


}

public void setSessionContext(SessionContext sesCtx) throws EJBException, 
RemoteException 
{



this.sesCtx = sesCtx;


}


public void ejbRemove() throws EJBException, RemoteException 
{


}


public void ejbActivate() throws EJBException, RemoteException 
{


}


public void ejbPassivate() throws EJBException, RemoteException 
{
}
}
BankClient.java
import java.io.DataInputStream;

import java.io.IOException;

import java.rmi.RemoteException;

import java.util.Hashtable;

import java.util.Properties;

import javax.ejb.CreateException;

import javax.ejb.RemoveException;

import javax.naming.Context;

import javax.naming.InitialContext;

import javax.naming.NamingException;

public class BankClient 
{


static String user = null;


static String password = null;


static String url = "t3://localhost:7001";

public static void main(String args[ ]) throws IOException
{



Hashtable hashtable = new Hashtable();



int bal, amt, ch;



String name, accNum, pwd;



DataInputStream dis = new DataInputStream(System.in);



try 
{




Context ctx = getInitialContext();




BankHome bankHome = (BankHome)ctx.lookup("beep");




BankRemote bankRemote = bankHome.create();




do 
{

System.out.println("1.Deposit\n 2.Withdraw\n 3.Balance\n 4.Exit");





System.out.println("Enter your choice:");





ch = Integer.parseInt(dis.readLine());





switch(ch)
{





case 1:






System.out.println("Enter Deposit Amount:");

bankRemote.deposit(java.lang.Float.parseFloat(dis.readLine()));
System.out.println("Your Money has been Deposited 
Successfully:);






break;





case 2:






System.out.println("Enter Withdraw Amount:");






try 
{

bankRemote.withDraw(java.lang.Float.parseFloat

(dis.readLine()

}

catch (Exception e) 
{







e.printStackTrace();






}

System.out.println("Your Money has been Debited Successfully:");






break;





case 3:






String curBal = bankRemote.getBalance();






System.out.println("Current Balance is:"+curBal);






break;





case 4:






bankRemote.remove();






System.exit(0);






default:







System.out.println("Wrong Choice:");





}




}while(ch!=4);



} 
catch (RemoteException re) 
{




re.printStackTrace();



}



catch (CreateException ce) 
{




ce.printStackTrace();



}



catch (RemoveException rem) 
{




rem.printStackTrace();



}



catch (NamingException ne) 
{




ne.printStackTrace();



}



catch (Exception e) 
{




e.printStackTrace();



}


}

static public Context getInitialContext() throws Exception 
{
Properties properties = new Properties();
properties.put(Context.INITIAL_CONTEXT_FACTORY,"
weblogic.jndi.T3InitialContextFactory");



properties.put(Context.PROVIDER_URL,url);

if(user!=null)
{




System.out.println("user:"+user);




properties.put(Context.SECURITY_PRINCIPAL,user);




if(password==null)





password="";




properties.put(Context.SECURITY_CREDENTIALS,password);



}



return new InitialContext(properties);


}

}

DatabaseAdaptor.java
import java.sql.Connection;

import java.sql.DriverManager;

public class DatabaseAdaptor 
{


private static String DRIVER, URL_DSN;


private static boolean isDriverLoaded = false;


public DatabaseAdaptor()
{



DRIVER = "sun.jdbc.odbc.JdbcOdbcDriver";



URL_DSN = "jdbc:BankDSN";


}


public Connection getConnection()
{



Connection con = null;



try 
{




if(!isDriverLoaded)
{





Class.forName(DRIVER);





isDriverLoaded = true;




}




con = DriverManager.getConnection(URL_DSN);



} 
catch (Exception e) 
{




e.printStackTrace();
}



return con;


}

}

Compilation and Execution Commands:

Server Path:
E:\Ejb\Bank >path= C:\Program Files\Java\jdk1.5.0_02\bin;
E:\Ejb\Bank >set classpath= C:\Program Files\Java\jdk1.5.0_02\bin;

E:\Ejb\Bank >set classpath=%classpath%;

E:\Ejb\Bank > javac *.java

E:\Ejb\Bank >C:\bea\weblogic81\server\bin\setWLSEnv;

Jar File Creation:

E:\Ejb\Bank >jar –cvf bankoper.jar *.class

Client Path:

E:\Ejb\Bank > path= C:\Program Files\Java\jdk1.5.0_02\bin;

E:\Ejb\Bank >set classpath= C:\Program Files\Java\jdk1.5.0_02\lib\jconsole.jar;

E:\Ejb\Bank > set classpath=%classpath%;

E:\Ejb\Bank > set classpath=%classpath%;C:\bea\weblogic81\server\lib\weblogic.jar;

E:\Ejb\Bank > C:\bea\weblogic81\server\bin\setWLSEnv;

E:\Ejb\Bank >java BankClient

OUTPUT:
1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

1

Enter Deposit Amount

5000.00

Successfully Deposited Thank You…..

1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

3

Your Current Balance is: 5000.00

1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

2

Enter Withdraw Amount

2000.00

Successfully Withdraw Thank You….

1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

3

Your Current Balance is: 3000.00
1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

2

Enter Withdraw Amount

4000.00

AccountException: Insufficient Balance!!!.....

1.Deposit

2.Withdraw

3.Balance

4.Exit

Enter Your Choice:

4

Exit
RESULT:

            Thus the program for creating  a component for banking operations using EJB was created and executed successfully.
Exp no: 4
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DEVELOP AN ENTERPRISE JAVA BEAN FOR LIBRARY DATE:


OPERATIONSLIBHOME.JAVA
AIM: -
              To Create a component for Library Operations using EJB.
DESCRIPTION

· Start the Process.

· Set the path for the given process.
· Define the Home Interface normally.

· Define the Remote Interface for the process determination.

·  Then the Implementation of  the EJB have to be determined.

· Accordingly the client program has to be written for the running process.

· Therefore the process has to be executed separately and perform the process.

· Finally execute the process.
EX.NO:4


                 DEVELOP AN ENTERPRISE JAVA BEAN FOR LIBRARY 


OPERATIONSLIBHOME.JAVA
DATE:

Codings:

import java.rmi.RemoteException;

import javax.ejb.CreateException;

import javax.ejb.EJBHome;

public interface LibHome extends EJBHome 

{


public LibRemote create(int id, String title, String author, int nc) throws








RemoteException, CreateException;

}

LibRemote.java

import java.rmi.RemoteException;

import javax.ejb.EJBObject;

public interface LibRemote extends EJBObject 

{

public boolean issue(int id, String title, String author, int nc)throws







RemoteException;


public boolean receive(int id, String title, String author, int nc)throws







RemoteException;


public int ncpy() throws RemoteException;

}

LibraryBean.java

import java.rmi.RemoteException;

import javax.ejb.EJBException;

import javax.ejb.SessionBean;

import javax.ejb.SessionContext;

public class LibraryBean implements SessionBean 

{


int bkid;


String tit;


String auth;


int nc1;


boolean status=false;

public void ejbCreate(int id,String title,String author,int nc)

{



bkid=id;



tit=title;



auth=author;



nc1=nc;


}


public int ncpy()

{



return nc1;

}


public boolean issue(int id,String  tit,String auth,int nc)

{



if(bkid==id)

{




nc1--;




status=true;



}



else 



status=false;



return(status);

}


public boolean receive(int id,String tit,String auth,int nc)

{



if(bkid==id)

{


nc1++;




status=true;



}



else



status=false;



return(status);

}


public void ejbActivate() throws EJBException, RemoteException 

{


}


public void ejbPassivate() throws EJBException, RemoteException 

{


}


public void ejbRemove() throws EJBException, RemoteException 

{


}


public void setSessionContext(SessionContext sesCxt) throws EJBException,









RemoteException 

{


}

}

LibClient .java

import java.io.BufferedReader;

import java.io.InputStreamReader;

import java.util.Properties;

import javax.naming.InitialContext;

import javax.rmi.PortableRemoteObject;

public class LibClient 

{

/**


 * @param args


 */


public static void main(String[ ] args) throws Exception 

{



Properties props = new Properties();

props.setProperty(InitialContext.INITIAL_CONTEXT_FACTORY, 

"weblogic.jndi.WLInitialContextFactory");



props.setProperty(InitialContext.PROVIDER_URL, "t3://localhost:7001");



props.setProperty(InitialContext.SECURITY_PRINCIPAL, "");



props.setProperty(InitialContext.SECURITY_CREDENTIALS, "");



InitialContext initialContext = new InitialContext(props);



Object objRef = initialContext.lookup("library2");



LibHome libHome = (LibHome) PortableRemoteObject.narrow(objRef, LibHome.class);



BufferedReader br = new BufferedReader(new InputStreamReader(System.in));



int ch;



String tit, auth;



int id, nc;



System.out.println("Enter the Details:");



System.out.println("Enter the Account Number:");



id = Integer.parseInt(br.readLine());



System.out.println("Enter the Book Title:");



tit = br.readLine();



System.out.println("Enter the Author:");



auth = br.readLine();



nc = Integer.parseInt(br.readLine());



int temp = nc;



do 

{




System.out.println("\t\t LIBRARY OPERATIONS:");




System.out.println("\t\t********************");




System.out.println("");




System.out.println("\t\t 1.ISSUE");




System.out.println("\t\t 2.RECEIVE");




System.out.println("\t\t 3.EXIT");




System.out.println("\t\t 4.ENTER UR OPTION:");




ch = Integer.parseInt(br.readLine());




LibRemote libRemote = libHome.create(id, tit, auth, nc);




switch(ch)

{




case 1:





System.out.println("Entering:");





nc = libRemote.ncpy();





if(nc>0)

{






if(libRemote.issue(id, tit, auth, nc))

{







System.out.println("BOOK ID IS:"+id);







System.out.println("BOOK TITLE IS:"+tit);







System.out.println("BOOK AUTHOR IS:"+auth);






System.out.println("NO.OF 

COPIES:"+libRemote.ncpy());







nc = libRemote.ncpy();







System.out.println("Success:");







break;






}





}





else 





System.out.println("Book is not available:");





break;




case 2:






System.out.println("Entering:");






if(temp>nc)

{







System.out.println("Temp:"+temp);






}






if(libRemote.receive(id, tit, auth, nc))

{







System.out.println("BOOK ID IS:"+id);







System.out.println("BOOK TITLE IS:"+tit);







System.out.println("BOOK AUTHOR IS:"+auth);







System.out.println("NO.OF 

COPIES:"+libRemote.ncpy());







nc = libRemote.ncpy();







System.out.println("Success:");







break;






}






else






System.out.println("Invalid Transaction:");






break;

case 3:






System.exit(0);




}



} while (ch<=3 && ch>0);


}

}

Compilation and Execution Commands:

Server Path:

E:\Ejb\Lib>path= C:\Program Files\Java\jdk1.5.0_02\bin;

E:\Ejb\Lib>set classpath= C:\Program Files\Java\jdk1.5.0_02\bin;

E:\Ejb\Lib>set classpath=%classpath%;

E:\Ejb\Lib> javac *.java

E:\Ejb\Lib>C:\bea\weblogic81\server\bin\setWLSEnv;

Jar File Creation:

E:\Ejb\Lib>jar –cvf liboper.jar *.class

Client Path:

E:\Ejb\Lib> path= C:\Program Files\Java\jdk1.5.0_02\bin;

E:\Ejb\Lib>set classpath= C:\Program Files\Java\jdk1.5.0_02\lib\jconsole.jar;

E:\Ejb\Lib> set classpath=%classpath%;

           

 E:\Ejb\Lib> set classpath=%classpath%; C:\bea\weblogic81\server\lib\weblogic.jar;

E:\Ejb\Lib> C:\bea\weblogic81\server\bin\setWLSEnv;

E:\Ejb\Lib>java LibClient

OUTPUT:
Enter the Details
Enter the Account Number: 101
Enter the Book Title: Core Java

Enter the Author: Balaguru Samy

Enter the no.of.copies: 2


LIBRARY OPERATIONS
1.ISSUE



2.RECEIVE



3.EXIT



ENTER YOUR OPTION: 2

Entering Invalid Transaction

LIBRARY OPERATIONS
1.ISSUE



2.RECEIVE



3.EXIT



ENTER YOUR OPTION: 1

Entering valid Transaction

BOOK ID IS: 101

BOOK TITLE IS: Core Java

BOOK AUTHOR IS: Balaguru Samy

NO.OF.COPIES: 1

Success


LIBRARY OPERATIONS

1.ISSUE


2.RECEIVE



3.EXIT



ENTER YOUR OPTION: 2

BOOK ID IS: 101

BOOK TITLE IS: Core Java

BOOK AUTHOR IS: Balaguru Samy

NO.OF.COPIES: 2

Success

LIBRARY OPERATIONS
1.ISSUE



2.RECEIVE



3.EXIT



ENTER YOUR OPTION: 3

E:\Ejb\Lib>
RESULT:
       Thus the program for creating  a component for Library Operations using EJB was created and executed successfully.
Exp no: 5








     Date:

CREATE AN ACTIVE-X CONTROL FOR FILE OPERATIONS
AIM:- 

           To Create an Activex Control for File Operations
DESCRIPTION: 
Process:1

1. Start the process.

2. Open Visual Studio.net

3. File->New->Project->VisualBasic Projects->Windows Control Library.
4. Rename the Project as actfileoperation and click ok

5. drag and drop the following control

i. one Label box

ii. one Rich Text Box

iii. four Button

6. The following code must be included in their respective Button Click Event

Public Class FileControl

    Inherits System.Windows.Forms.UserControl

Dim fname As String

· new
· open
· save

· font

process:2
1. Open Visual Studio.net.
2. File->New->Project->VisualBasic Projects->Windows Application.
3. Rename the Project as actref and click ok.
4. Tools->Add/Remove Tool Box Item and select the tab  .NET Framework Components. 
Click the Browse Button and open the actfileoperation.dll from (locate the bin folder) and click ok.and execute finally.and execute it... 
EX.NO:5
    

                         CREATE AN ACTIVE-X CONTROL FOR FILE       

                                             OPERATIONS
DATE:

Codings:

Dim f As New FileSystemObject

Dim t As TextStream

Dim s1 As String

Public Sub filecreation(s As String)

On Error GoTo X

s1 = s

If (s1 = "") Then

    MsgBox ("Please enter the filename")

Else

    If (f.FileExists(s1) = False) Then

        f.CreateTextFile (s1)

        MsgBox ("File Created")

    Else

        MsgBox ("File Already created")

    End If

End If

Exit Sub

X:

MsgBox ("Error in File Creation")

End Sub

Public Sub filewrite(a As String)

On Error GoTo X

If (s1 = "") Then

    MsgBox ("Please enter the filename")

Else

    If (f.FileExists(s1) = True) Then

        Set t = f.OpenTextFile(s1, ForWriting, True)

     t.WriteLine (a)

        MsgBox ("File Written")

        t.Close

    Else

        MsgBox ("File Doesnt Exist")

    End If

    End If

Exit Sub

X:

MsgBox ("Error in File Writing")

End Sub

Public Sub fileappend(a As String)

On Error GoTo X

If (s1 = "") Then

    MsgBox ("Please enter the filename")

Else

    If (f.FileExists(s1) = True) Then

        Set t = f.OpenTextFile(s1, ForAppending, True)

        t.WriteLine (a)

        MsgBox ("File Appended")

        t.Close

    Else

        MsgBox ("File not Exist")

    End If

End If

Exit Sub

X:

MsgBox ("Error in File Appending")

End Sub

Public Function fileread(s) As String

On Error GoTo X

Dim k As String

If (s = "") Then

    MsgBox ("Please enter the filename")

Else

If (f.FileExists(s) = True) Then

    Set t = f.OpenTextFile(s, ForReading, True)

    While (t.AtEndOfStream = False)

        k = k & " " & t.ReadLine

    Wend

    fileread = k

    t.Close

Else

    MsgBox ("File Not Exist")

End If

End If

Exit Function

X:

MsgBox ("Error in Reading")

End Function

Public Sub filedelete(s)

On Error GoTo X

If (s = "") Then

    MsgBox ("Please enter the filename")

Else

    If (f.FileExists(s) = True) Then

        f.DeleteFile (s)

        MsgBox ("File Deleted")

    Else

        MsgBox ("File Doesnt Exist")

    End If

End If

Exit Sub

X:

MsgBox ("Error in File Deletion")

End Sub

// Standard Project (with Three textboxes and six command buttons)

Dim t As New FileActivex.Class1

Private Sub Command1_Click()

t.filecreation (Trim(Text3.Text))

End Sub

Private Sub Command2_Click()

t.filewrite (Trim(Text1.Text))

End Sub

Private Sub Command3_Click()

t.fileappend (Trim(Text1.Text))

End Sub

Private Sub Command4_Click()

Text2.Text = t.fileread(Trim(Text3.Text))

End Sub

Private Sub Command5_Click()

t.filedelete (Trim(Text3.Text))

End Sub

Private Sub Command6_Click()

End

End Sub
EXECUTION:
// Activex DLL Project
1. Open "activex Dll" project in VB

2. Give the reference to "c:\windows\system32\scrrun.dll” (for FileSystemObject)

   Project (Reference ( (check) Microsoft scripting Runtime

3. Type the coding for File operation

4. Make the dll file

   File ("Make Project1.dll"

// Standard Project

1. Open a new standard application project in VB

2. Give the reference to the dll file (Project1.dll)

    Project (Reference (Browse (Select the project1.dll by navigate to the file location

3. Design the VB Form

4. Type the coding

5. Execute the application

OUTPUT:
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RESULT:

         Thus the program for creating  an Activex Control for File Operations was created and executed successfully.
Exp no: 6







                        Date:


DEVELOP A COMPONENT FOR CONVERTING THE DATE:


CURRENCY VALUES USING COM/.NET
AIM:
             To Create an component for currency conversion using com/.net.
DESCRIPTION: 

Process:1

CREATE A COMPONENT 

· Start the process .
· open VS .NET  .
· File-> New-> Project-> visual Basic Project -> class library, rename the class Library if required.
· include the following coding in the class Library

· Public Function dtor.
· Public Function rtoe
· Public Function rtod
· Public Function etor
· Build->Build the solution.
Process:2

REFERENCING THE COMPONENT 

· Start the process .
· open VS .NET  .
· File-> New-> Project-> visual Basic Project -> Windows Application, rename the Windows Application if required.
· Project -> Add Reference choose the com tab->Browse the dollartorupees.dll and click ok.
· Finally execute the process in a deterministic manner.
EX.NO:6



                             DEVELOP A COMPONENT FOR CONVERTING THE


CURRENCY VALUES USING COM/.NET
DATE:

Codings:

Public Class Form1

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

 End Sub

Private Sub Label3_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Label3.Click

 End Sub

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click

 If ComboBox1.SelectedItem = "Dollar" And ComboBox2.SelectedItem = "Dollar" Then

            





TextBox2.Text = "$" & TextBox1.Text

ElseIf ComboBox1.SelectedItem = "Dollar" And ComboBox2.SelectedItem = "Euro" Then

            




TextBox2.Text = "E" & Val(TextBox1.Text) / 1.5

ElseIf ComboBox1.SelectedItem = "Dollar" And ComboBox2.selectedItem = "yen" Then

            




TextBox2.Text = "Y" & Val(TextBox1.Text) * 135

ElseIf ComboBox1.SelectedItem = "Dollar" And ComboBox2.selectedItem = "Rupees" Then

            




TextBox2.Text = "Rs." & Val(TextBox1.Text) * 45

End If

If ComboBox1.SelectedItem = "Euro" And ComboBox2.selectedItem = "Dollar" Then

            




TextBox2.Text = "$" & Val(TextBox1.Text) * 1.5

 ElseIf ComboBox1.SelectedItem = "Euro" And ComboBox2.SelectedItem = "Euro" Then

           



 TextBox2.Text = "E" & TextBox1.Text

ElseIf ComboBox1.SelectedItem = "Euro" And ComboBox2.SelectedItem = "Yen" Then

            




TextBox2.Text = "Y" & Val(TextBox1.Text) * 165

ElseIf ComboBox1.SelectedItem = "Euro" And ComboBox2.SelectedItem = "Rupees" Then

            




TextBox2.Text = "Rs." & Val(TextBox1.Text) * 50

End If

 If ComboBox1.SelectedItem = "Yen" And ComboBox2.SelectedItem = "Dollar" Then

            




TextBox2.Text = "$" & (TextBox1.Text) / 135

 ElseIf ComboBox1.SelectedItem = "Yen" And ComboBox2.SelectedItem = "Euro" Then

            




TextBox2.Text = "E" & Val(TextBox1.Text) / 165

 ElseIf ComboBox1.SelectedItem = "Yen" And ComboBox2.SelectedItem = "Yen" Then

            




TextBox2.Text = "Y" & TextBox1.Text

 ElseIf ComboBox1.SelectedItem = "Yen" And ComboBox2.SelectedItem = "Rupees" Then

            




TextBox2.Text = "Rs." & Val(TextBox1.Text) / 30

End If

If ComboBox1.SelectedItem = "Rupees" And ComboBox2.SelectedItem = "Dollar" Then

            




TextBox2.Text = "$" & Val(TextBox1.Text) / 45

ElseIf ComboBox1.SelectedItem = "Rupees" And ComboBox2.SelectedItem = "Euro" Then

            




TextBox2.Text = "E" & Val(TextBox1.Text) / 50

 ElseIf ComboBox1.SelectedItem = "Rupees" And ComboBox2.SelectedItem = "Yen" Then

            




TextBox2.Text = "Y" & Val(TextBox1.Text) * 30

 ElseIf ComboBox1.SelectedItem = "Rupees" And ComboBox2.SelectedItem = "Rupees" Then

            




TextBox2.Text = "Rs." & TextBox1.Text

 End If

  End Sub

 End Class

OUTPUT:
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RESULT:

                   Thus the program for creating  a component for currency conversion using com/.net  was created and executed successfully.
Exp no: 7







                     Date:


DEVELOP A COMPONENT FOR ENCRYPTION AND


                       DECRYPTION USING COM/.NET
AIM:
              To Develop a component for cryptography using COM/.NET.
DESCRIPTION: 

a) CREATE A COMPONENT 
· Start the given process.
· open VS .NET.
· File-> New-> Project-> visual Basic Project -> class library, rename the class Library if required.
· Then include the library function and determine its function accordingly.

b) REFERENCING THE COMPONENT 
· Start the process .
· open VS .NET . 

· 3.File-> New-> Project-> visual Basic Project -> Windows Application, rename the Windows Application if required.
· 4.Project -> Add Reference choose the com tab->Browse the encode.dll and click ok.
· 5.Drag and Drop the following controls in the form

· 2 Label Boxes

· 1 Text box

· 3 Buttons

· Finally execute the process in a deterministic manner.
EX.NO:7



DEVELOP A COMPONENT FOR ENCRYPTION AND
DECRYPTION USING COM/.NET
DATE:

Codings:

public class form1
Dim a As char()
Dim otemp As char
Dim i As integer
Dim tem As integer
Dim st As string
private sub button1_click(By val sender As system object By val e As system.
event args)Handles Button1_click
st="  "
a=TextBox1.text.to char array
i=a.length
for i=0 To a length-1
tem=Asc(a(i))
otem=chr(tem)
st&=0temp
Next
TextBox2.Text=st
end sub

private sub button3_click(By val sender As system object By val e As system.
event args)Handles Button3_click

TextBox1.Text=""
TextBox2.Text=""
TextBox3.Text=""
TextBox4.Text=""

 private sub button2_click(By val sender As system object By val e As system.
event args)Handles Button2_click

st=""
a=TextBox2.text.to char array
for i=0 To a length-1
tem=Asc(a(i))
tem=tem-5
otem=chr(tem)
st&=0temp
Next
TextBox3.Text=st
end sub

private sub button4_click(By val sender As system object By val e As system.
event args)Handles Button4_clicK

me close()
End sub
End class
OUTPUT:
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RESULT:

                   Thus the program for Developing  a component for cryptography using COM/.NET was created and executed successfully.
Exp no: 8






                            Date:

DEVELOP A COMPONENT FOR RETRIEVING
INFORMATION FROM MESSAGEBOX USING DCOM/.NET
AIM: 
   To Create a component to retrieve message box information using   DCOM/.NET.
DESCRIPTION:

                      Process:1

· Start the process..
· Open Visual Studio. NET..
· Goto File->New->Project->ClassLibrary|Empty Library->OK.
· Goto Solution Explorer->Right Click->Add->Add Component|Add New Item->COM Class-_OK.
Process:2

· Go To Start->Microsoft Visual.Net 2003->Visual Stufio.Net tools->Command prompt.
· Setting environment for using Microsoft Visual Studio .NET 2003 tools.

· start -> settings -> control panel->administrative tools->component services-> computer->my computer->com + Application -> new -> application ->next -> create an empty application-> choose the server Application -> enter the new Application name (mssg) -> next ->choose the interactive user-> next->finish..
Process:3

· Open  Visual studio .net -> file-> new ->Project->Windows Application.
· Create one label box,one text box and one button in the form.
· End Class.
· execute the project.
· Finally execute the process in a deterministic manner. 
EX.NO:8

             DEVELOP A COMPONENT FOR RETRIEVING 
              INFORMATION FROM MESSAGEBOX USING  

                                                    DCOM/.NET
DATE:

Codings:

Public Class Form1

Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) 
Handles Button1.Click

Dim a As String = MessageBox.Show("The calculations are complete","My 
Application",MessageBoxButtons.YesNoCancel,MessageBoxIcon.Asterisk)
 If a = "6" Then

 
MsgBox("yes")

 ElseIf a = "7" Then

            MsgBox("no")
 ElseIf a = "2" Then

            MsgBox("Hai")
End If

End Sub

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) 
Handles MyBase.Load
End Sub

End Class
OUTPUT:
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RESULT:

                   Thus the program for Developing  a component to retrieve message box information using COM/.NET was created and executed successfully.
Exp no: 9





                                       Date:

DEVELOP A MIDDLEWARE COMPONENT FOR                                         RETRIEVING STOCK   MARKET EXCHANGE INFORMATION    USING CORBA
AIM: 
              To Create a Component for retrieving stock market exchange information using CORBA.
DESCRIPTION:

· Define the IDL interface.
· Implement the IDL interface using idlj compiler.
· Create a Client Program.
· Create a Server Program.
· Start orbd..
· Start the Server.

· Start the client.
· Finally execute the process in a deterministic manner.
EX.NO:9



Develop a middleware component for retrieving stock
market exchange information using corba
DATE:
Codings:

Stock Server.java

import StockApp.*;

import org.omg.CosNaming.*;

import org.omg.CORBA.*;

import org.omg.CORBA.Object;

import org.omg.CosNaming.NamingContextPackage.*;

import org.omg.PortableServer.*;

import org.omg.PortableServer.POA;

class StockImpl extends StockPOA 
{
private ORB orb;


public void setORB(ORB j) 
{
orb = j;


}


public double input(double unit, double no)
{



return (unit * no);


}

}
public class StockServer 
{
public static void main(String[ ] args) 
{
try 
{



ORB orb = ORB.init(args, null);



POA rootPOA =POAHelper.narrow(orb.resolve_initial_references("RootPOA"));



rootPOA.the_POAManager().activate();



StockImpl stockImpl = new StockImpl();



stockImpl.setORB(orb);



Object objectRef1 = rootPOA.servant_to_reference(stockImpl);



Stock stockRef = StockHelper.narrow(objectRef1);



org.omg.CORBA.Object objectRef2 = 
orb.resolve_initial_references("NameService");



NamingContextExt ncRef = NamingContextExtHelper.narrow(objectRef2);



String name = "P1";



NameComponent ncPath[ ] = ncRef.to_name(name);



ncRef.rebind(ncPath, stockRef);



System.out.println("Server is Ready & Waiting.....");



orb.run();


} 
catch (Exception e) 
{


System.out.println("ERROR:"+e);




e.printStackTrace();


}

      }

}
Stock Client.java
import StockApp.*;
import org.omg.CosNaming.*;

import java.io.BufferedReader;

import java.io.InputStreamReader;

import org.omg.CORBA.ORB;

import org.omg.CosNaming.NamingContextExt;

import org.omg.CosNaming.NamingContextExtHelper;

public class StockClient 
{

static Stock stock;

public static void main(String args [ ])
{



String[ ] uid1 = { "M124", "p1190", "m890", "k345"};



String[ ] p = {"HUTCH", "Infosys","Hutch","Infosys"};



double [ ] unit = {5,6,5,6};



double [ ] noshares = {10,4,7,3};



double [ ] total = {0,0,0,0};



int ch;



try 
{




ORB orb = ORB.init(args, null);




org.omg.CORBA.Object objectRef = 
orb.resolve_initial_references("NamingService");




NamingContextExt namingContextRef = 
NamingContextExtHelper.narrow(objectRef);




String name = "p1";




stock = StockHelper.narrow(namingContextRef.resolve_str(name));




for (int i=0; i<4; i++)




total[i] = stock.input(unit[i], noshares[i]);




System.out.println("STOCK MARKER EXCHANGE:");




System.out.println("----------------------");




System.out.println("STATUS OF NSE:");




System.out.println("------------");




System.out.println("Uid Company name \t unit\t No.of.Shares\t total:");




for (int i=0; i<4; i++) 
{
System.out.println("\t"+uid1[i]+"\t"+p[i]+"\t"+unit[i]+"\t\t"+nosha
res[i]+"\t\t"+total[i]);




}




BufferedReader bufferedReader = new BufferedReader(new 
InputStreamReader(System.in));




String choice = "y";




Do
 
{





System.out.println("\t\t Menu Option:");





System.out.println("\n 1.Buy, \n2.Sell, \n 3.Display");





System.out.println("Enter ur Choice:");





ch = Integer.parseInt(bufferedReader.readLine());





switch(ch)
{





case 1:






System.out.println("Enter Buyer ID:");






String str1 = bufferedReader.readLine();






System.out.println("Enter Company Name:");






String str2 = bufferedReader.readLine();






System.out.println("No of Shares u want to buy:");






double doub1 = 
Double.parseDouble(bufferedReader.readLine());






System.out.println("Enter the Seller id:");






String str3 = bufferedReader.readLine();






for (int i=0; i<4; i++)
{







if (uid1 [i].equals(str1))
{








if(p [i].equals(str2))
{









noshares[i] = noshares[i] + doub1;









total[i] = unit[i] * noshares[i];








}







}






}






for (int i=0; i<4; i++)
{







if (uid1 [i].equals(str3))
{








if(p [i].equals(str2))
{









noshares[i] = noshares[i] - doub1;









total[i] = unit[i] * noshares[i];








}







}






}






break;




case 2:





System.out.println("Enter Seller ID:");





String str4 = bufferedReader.readLine();





System.out.println("Enter Company Name:");





String str5 = bufferedReader.readLine();





System.out.println("No of Shares u want to buy:");





double doub2 = Double.parseDouble(bufferedReader.readLine());





System.out.println("Enter the Seller id:");





String str6 = bufferedReader.readLine();





for (int i=0; i<4; i++)
{






if (uid1 [i].equals(str4))
{







if(p [i].equals(str5))
{








noshares[i] = noshares[i] - doub2;








total[i] = unit[i] * noshares[i];







}






}





}





for (int i=0; i<4; i++)
{






if (uid1 [i].equals(str6))
{







if(p [i].equals(str5))
{








noshares[i] = noshares[i] + doub2;








total[i] = unit[i] * noshares[i];







}






}





}





break;




case 3:





System.out.println("\t\t Status of NSE:");





System.out.println("\t uid \t Company name \t\t unit \t 
No.of.Share\t total:");





for (int i=0; i<4; i++)
{
System.out.println("\t"+uid1[i]+"\t"+p[i]+"\t"+unit[i]+"\t\t"
+noshares[i]+"\t\t"+total[i]);





}





break;




}




System.out.println("Do you want to continue Y/N:");




choice = bufferedReader.readLine();




} while (choice.equals("y"));



}
 catch (Exception e) 
{




System.out.println("ERROR:"+e);




e.printStackTrace();



}


}

}

Stock.idl

module StockApp

{


interface Stock


{



double input (in double unit, in double rate);


};

};
OUTPUT:

E:\Corba>set PATH=%PATH%.; E:\Corba;

E:\Corba>set CLASSPATH=%CLASSPATH%.; E:\Corba;

E:\Corba>idlj Stock.idl

E:\Corba>idlj -fall Stock.idl

E:\Corba>javac *.java StockApp/*.java

Note: StockApp/StockPOA.java uses unchecked or unsafe operations.

Note: Recompile with -Xlint:unchecked for details.

E:\Corba>Start orbd -ORBInitialPort 1050

E:\Corba>Start java StockServer -ORBInitialPort 1050 -ORBInitialHost localhost

E:\Corba>Start java StockClient -ORBInitialPort 1050 -ORBInitialHost localhost





STOCK MARKET EXCHANGE






STATUS OF NSE

-------------------------------------------------------------------------------------


uid
Company name

unit
     No.of.shares

total


-------------------------------------------------------------------------------------


M124
HUTCH

5.0

10.0

50.0


Pl190
Infosys


6.0

4.0

24.0


M890
Hutch


5.0

7.0

35.0


K345
Infosys


6.0

3.0

18.0


-------------------------------------------------------------------------------------

Menu Options

1. Buy

2. Sell

3. Display

Enter your choice: 1

Enter Buyer ID: M124

Enter Company Name: Hutch

No.of.shares you want to buy: 5

Enter the Seller ID: 1

Do you want to continue y/n: y
Menu Options

1. Buy

2. Sell

3. Display

Enter your choice: 3

STATUS OF NSE

-------------------------------------------------------------------------------------


uid
Company name

unit
     No.of.shares

total


-------------------------------------------------------------------------------------


M124
HUTCH

5.0

15.0

75.0


Pl190
Infosys


6.0

4.0

24.0


M890
Hutch


5.0

7.0

35.0


K345
Infosys


6.0

3.0

18.0

-------------------------------------------------------------------------------------

Do you want to continue y/n: y
Menu Options

1. Buy

2. Sell

3. Display

Enter your choice: 2

Enter Seller ID: 2

Enter Company Name: Infosys

No.of.shares you want to buy: 5

Enter the Buyer ID: k345

Do you want to continue y/n: y

Menu Options
1. Buy

2. Sell

3.Display
Enter your choice: 3

STATUS OF NSE

-------------------------------------------------------------------------------------


uid
Company name

unit
     No.of.shares

total


-------------------------------------------------------------------------------------


M124
HUTCH

5.0

15.0

75.0


Pl190
Infosys


6.0

4.0

24.0


M890
Hutch


5.0

7.0

35.0


K345
Infosys


6.0

8.0

48.0

-------------------------------------------------------------------------------------

Do you want to continue y/n: n

RESULT:
                  Thus the program for creating  a Component for retrieving stock market exchange information using CORBA was created and executed successfully.
Exp no: 10





                                       Date:

Develop a Middleware Component for Retrieving Weather Forecast Information using CORBA

AIM:
         To Create a Component for retrieving stock market exchange information using CORBA
DESCRIPTION:

· Define the IDL interface

· Implement the IDL interface using idlj compiler

· Create a Client Program

· Create a Server Program

· Start orbd.

· Start the Server.

· Start the client

· finally execute the process in a deterministic manner 

EX.NO:10


Develop a Middleware Component for Retrieving Weather
Forecast Information using CORBA
DATE:
Codings:

WeatherServer.java

import org.omg.CORBA.ORB;

import org.omg.CORBA.Object;

import org.omg.CosNaming.NameComponent;

import org.omg.CosNaming.NamingContextExt;

import org.omg.CosNaming.NamingContextExtHelper;

import org.omg.PortableServer.POA;

import org.omg.PortableServer.POAHelper;

public class WeatherServer 
{

public static void main(String[ ] args) 
{

try 
{




ORB orb = ORB.init(args, null);




POA rootPOA = 
POAHelper.narrow(orb.resolve_initial_references("RootPOA"));




rootPOA.the_POAManager().activate();




WeatherImpl weatherImpl = new WeatherImpl();




weatherImpl.setORB(orb);




Object objectRef1 = rootPOA.servant_to_reference(stockImpl);




Weather weatherRef = WeatherHelper.narrow(ref);




org.omg.CORBA.Object objectRef2 = 
orb.resolve_initial_references("NameService");




NamingContextExt ncRef = 
NamingContextExtHelper.narrow(objectRef2);




String name = "Hello";




NameComponent ncPath[ ] = ncRef.to_name(name);




ncRef.rebind(ncPath, weatherRef);




System.out.println("Server is Ready & Waiting.....");




orb.run();



}
 catch (Exception e)
 {




System.out.println("ERROR:"+e);




e.printStackTrace();

}



System.out.println("Server Exsisting:.....");

} 

}

WeatherImpl.java
import org.omg.CORBA.ORB;
public class WeatherImpl extends WeatherPOA 
{


private ORB orb;


private double current;


private double min;


private double max;


public void setORB(ORB orb_val)
{



orb = orb_val;


}


public void adjustTemp(double g)
{



Current+=g;



if(current > max)




max =current;



else if(current<min)




min = current;


}


public double getMax()
{



return max;


}


public double getMin()
{



return min;


}


public double getCurrent()
{



return current;


}


public void call1(double doub)
{



min = max = current = doub;


}


public void shutdown()
{



orb.shutdown(false);


}

}

WeatherClient.java

import org.omg.CORBA.ORB;

import org.omg.CosNaming.NamingContextExt;

import org.omg.CosNaming.NamingContextExtHelper;

public class WeatherClient 
{

static Weather weather;

public static void main(String[ ] args) 
{


double[ ][ ] d1 = {{-1.5,4.2,5.8,-4.5},{-2.3,-7.8,6.2,-4.7},
{4.3,-2.5,3.5,-6.7},{-5.2,4.3,8.2,6.2}};


String [ ] str = {"Chennai","Mumbai","Delhi","Calcutta"};


try 
{



ORB orb = ORB.init(args, null);



org.omg.CORBA.Object objectRef = 
orb.resolve_initial_references("NamingService");



NamingContextExt namingContextRef = 
NamingContextExtHelper.narrow(objectRef);



String name = "Hello";



weather = WeatherHelper.narrow(namingContextRef.resolve_str(name));



weather.call1(20.0);



System.out.println("\n\n");



System.out.println("\t\t WEATHER FORECASTING");



System.out.println("\t\t *******************");



for (int j=0; j<4; j++)
{




System.out.println("\n\n");




System.out.println("City:"+str[j]);




for (int i=0; i<3; i++) 
{





weather.adjustTemp(d1[j][i]);




}




System.out.println("\t\t Maximum Temperature:"+weather.getMax());




System.out.println("\t\t Minimum Temperature:"+weather.getMin());



}




weather.shutdown();


} 
catch (Exception e) 
{



System.out.println("ERROR:"+e);



e.printStackTrace();


}

}
}

Weather.idl

module WeatherApp

{


interface Weather


{



void adjustTemp(in double r);



double getCurrent();



double getMax();



double getMin();



void call1(in double k);



oneway void shutdown();


};

};

OUTPUT:
E:\Corba>set PATH=%PATH%.; E:\Corba;

E:\Corba>set CLASSPATH=%CLASSPATH%.; E:\Corba;

E:\Corba>idlj Weather.idl

E:\Corba>idlj -fall Weather.idl

E:\Corba>javac *.java WeatherApp/*.java

Note: WeatherApp/WeatherPOA.java uses unchecked or unsafe operations.

Note: Recompile with -Xlint:unchecked for details.

E:\Corba>Start orbd -ORBInitialPort 1050

E:\Corba>Start java WeatherServer -ORBInitialPort 1050 -ORBInitialHost localhost

E:\Corba>Start java WeatherClient -ORBInitialPort 1050 -ORBInitialHost localhost

WEATHER FORECASTING

City: CHENNAI

Maximum Temperature: 28.5

Minimum Temperature: 18.5

City: MUMBAI

Maximum Temperature: 28.5

Minimum Temperature: 18.4

City: DELHI

Maximum Temperature: 29.9

Minimum Temperature: 18.4

City: KOLKATTA

Maximum Temperature: 37.2

Minimum Temperature: 18.4

RESULT:

                  Thus the program for creating  a Component for retrieving weather forecast  information using CORBA was created and executed successfully.
